0a5ff1a6e52a53e66e32486a96d852454f3afbc4

I de tidigare lektionerna har vi gått igenom hur man navigerar med hjälp av tangentbordet i Excel samt hur referenser hänger ihop. Vi har även skapat några väldigt enkla formler. Nu ska vi gå lite djupare och börja använda funktioner, som kan användas för att behandla data på olika sätt.

Som vi tidigare gått igenom så kan en cell innehålla siffror, text eller formler (som i sin tur kan generera antingen siffror eller text). Nu ska vi ta en titt på så kallade funktioner. Funktioner är ett koncept som kommer från matematiken och programmeringen: en funktion tar ett eller flera värden som indata och genererar utdata baserat på detta. Man kan se en funktion som en svart låda där man stoppar in saker och får ut något som beror på vad man stoppade in. Om man stoppar in flera olika saker i en funktion i Excel så håller man isär dessa saker med semikolon. Funktioner skrivs alltid som en del av en formel, dvs. med ett = i början, och avslutas med parenteser. Mellan parenteserna skrivs indata in, avgränsat med semikolon om man stoppar in flera olika saker. En funktion ser alltså ut såhär i Excel:


=FUNKTIONSNAMN(INDATA;INDATA2;INDATA3;...)

En av de vanligaste funktionerna i Excel är SUMMA(), som tar ett eller flera tal och spottar ur sig summan av dessa. På engelska heter den SUM() och här är några exempel på hur den fungerar:

=SUMMA(A1;A3;A5) summerar talen A1, A3 och A5.
=SUMMA(A1:A5;A10) summerar talen i området A1-A5 och talet A10.
=SUMMA(A1:A10)+SUMMA(A15;A20) är en formel som använder funktionen SUMMA() två gånger, först för att summera talen i området A1-A10, sedan talen i A15 och A20. Till sist lägger formeln ihop dessa två summor.

Hängde du med? En funktion kan alltså vara en del i en formel. Faktum är att en formel kan ingå i en funktion också, såsom i funktionen OMFEL():

=OMFEL(A1+A2;"Det blev fel!") försöker summera fälten A1 och A2 med hjälp av formeln A1 + A2, men om detta går fel (t.ex. för att A2 innehåller text) så spottar funktionen ur sig texten "Det blev fel!" istället.

Dessutom kan en funktion användas i en funktion:

=OMFEL(SUMMA(A1:A3);"Fel!") försöker räkna ut summan av cellerna i området A1 - A3, men om detta går fel så skrivs "Fel!" ut istället. 

Några av de vanligaste funktionerna i Excel är:

=MEDEL(A1:A20) räknar ut medelvärdet av talen i området A1-A20
=MAX(A1:A20) hittar det största värdet av talen i området A1-A20
=MIN(A1:A20) hittar det minsta värdet av talen i området A1-A20
=OM(A1>20;1;0) visar 1 om innehållet i A1 är större än 20, annars visas 0

Fler vanliga funktioner i Excel kan du t.ex. hitta här:

https://www.udemy.com/blog/excel-formulas/


Dagens uppgift:

Skapa ett Excelark som innehåller alla veckodagar i cellerna A2-A8. Utgå från föregående vecka och skriv sedan in i kolumn B hur många koppar kaffe du drack per dag under veckan (om du inte kommer ihåg kan du chansa). Räkna sedan med hjälp av Excels funktioner hur många koppar kaffe du drack totalt under veckan samt hur många koppar du drack den dag du drack mest kaffe.